Lucent Omni Stack LS 6224

Материал из Wiki
Перейти к: навигация, поиск


Lucent Omni Stack LS 6224

В руки попал коммутатор Lucent Omni Stack LS 6224. Задача - всесторонне протестировать.
При цене $296 прямой конкурент DES-3526

Сравнительная характеристика

В таблице указаны фичи и

Authentication

Console, Telnet, web – User name / password, RADIUS, TACACS+ Web – HTTPS; Telnet – SSH SNMP v1/2c - Community strings SNMP version 3 – MD5 or SHA password Port – IEEE 802.1x

Все вцелом аналогично Длинку. Из плюсов - ssh работает с приемлемой скоростью.

Access Control Lists

Supports up to 1K IP or MAC ACLs

Пока сложно сказать, но Content-Filter у Длинка достаточно гибкие, хотя их и не много. TODO: Cравнить подробнее.

DHCP Client

Supported

Фича сомнительной необходимости, есть у всех.

DNS Server

Supported

Назначение неясно. TODO:Уточнить

Port Configuration

Speed, duplex mode and flow control

У всех коммутатров абсолютно одинаково.

Rate Limiting

Input and output rate limiting per port

с каким шагом? TODO: уточнить

Port Mirroring

One or more ports mirrored to single analysis port

Стандартная фича. TODO: Проверить работу.

Port Trunking

Supports up to 8 trunks using either static or dynamic trunking (LACP)

Стандартная фича.

Broadcast Storm Control

Supported

TODO: Проверить работу.

Static Address

Up to 16K MAC addresses in the forwarding table

Уточнить что имелось ввиду. статик мак в современной провайдерской сети скорее вреден. Если размер таблицы коммутации 16к - то это хороший результат.

IEEE 802.1D Bridge

Supports dynamic data switching and addresses learning

Store-and-Forward Switching

Supported to ensure wire-speed switching while eliminating bad frames

Spanning Tree Protocol

Supports standard STP, Rapid Spanning Tree Protocol (RSTP), Multiple Spanning Trees (MSTP).

Насколько стабильна работа?

Virtual LANs

Up to 255 using IEEE 802.1Q, port-based, protocol-based, or private VLANs GVRP

255 Вланов вполне достаточно для коммутатора доступа.

Traffic Prioritization

Default port priority, traffic class map, queue scheduling, IP Precedence, or Differentiated Services Code Point (DSCP) and TCP/UDP Port

Проверить работу, хотя фактически на данный момент мне не нужна приоритезация траффика.

STP Root Guard

Prevents devices outside the network core from being assigned the spanning tree root.

STP BPDU Guard

Used as a security mechanism to protect the network from invalid configurations.

802.1x - MAC Authentication

MAC authentication ensures that end-user stations meet security policies criteria, and protects networks from viruses.

Не использую.

DHCP Snooping

Expands network security by providing a firewall security between untrusted interfaces and DHCP servers.

Совершенно необходимая фича. Проверить работу.

DHCP Option 82

Enables to add information for the DHCP server on request.

Совершенно необходимая фича.

IP Source Address Guard

Restricts IP traffic on non-routed, Layer 2 interfaces by filtering traffic. This feature is based on the DHCP snooping binding database and on manually configured IP source bindings.

Совершенно необходимая фича.

ARP Inspection

Classic Address Resolution Protocol is a TCP/IP protocol that translates IP addresses into MAC addresses.

Загрузка

Подключенеи через консольный кабель, 9600 8N1

RJ45-
1. бело-оранжевый
2. оранжевый
3. бело-зелёный
4. синий
5. бело-синий
6. зелёный
7. бело-коричневый
8. коричневый.

DB9
1. пусто...
2. зеленый
3. бело-зеленый
4. оранжевый
5. синий,бело-синий
6. бело-коричневый
7. бело-оранжевый
8. коричневый
9. пусто...

Кабель зеркальный относительно Cisco, и предположительно может быть собран из roll-over кабеля.

Welcome to minicom 2.3

OPTIONS: I18n
Compiled on Jan  1 2009, 02:50:29.
Port /dev/ttyUSB0

                 Press CTRL-A Z for help on special keys


Boot1 Checksum Test...............................PASS

Boot2 Checksum Test...............................PASS

Flash Image Validation Test.......................PASS



BOOT Software Version 1.0.0.12 Built  19-Oct-2006  09:07:37

 OS6200 board, based on PPC8247
 128 MByte SDRAM. I-Cache 16 KB. D-Cache 16 KB. Cache Enabled.

Autoboot in 2 seconds - press RETURN or Esc. to abort and enter prom.
Preparing to decompress...
 100%
Decompressing SW from image-2
 100%

OK
Running from RAM...

*********************************************************************
*** Running  SW  Ver. 1.5.0.93  Date  15-Jun-2007  Time  12:08:50 ***
*********************************************************************

HW version is 00.00.01
Base Mac address is: 00:12:хх:хх:хх:хх
Dram size is  : 128M bytes
Dram first block size is  : 98304K bytes
Dram first PTR is  : 0x2000000
Flash size is: 16M
01-Jan-2000 01:01:04 %CDB-I-LOADCONFIG: Loading running configuration.
01-Jan-2000 01:01:04 %CDB-I-LOADCONFIG: Loading startup configuration.
Device configuration:
CPLD revision:  1.03
PCB revision: R-0A
Slot 1 - OmniStack LS 6224 HW Rev.  1.3

------------------------------------
-- Unit Standalone                --
------------------------------------

Tapi Version: v1.3.3.1
Core Version: v1.3.3.1
01-Jan-2000 01:01:19 %INIT-I-InitCompleted: Initialization task is completed


01-Jan-2000 01:01:19 %SNMP-I-CDBITEMSNUM: Number of running configuration items loaded: 2

01-Jan-2000 01:01:19 %SNMP-I-CDBITEMSNUM: Number of startup configuration items loaded: 2
01-Jan-2000 01:01:20 %Box-I-SFP-PRESENT-CHNG: unit_id 1 SFP 0 status is not present.
01-Jan-2000 01:01:20 %Box-I-SFP-PRESENT-CHNG: unit_id 1 SFP 1 status is not present.

console> 01-Jan-2000 01:01:22 %LINK-W-Down:  e1
01-Jan-2000 01:01:22 %LINK-W-Down:  e2
01-Jan-2000 01:01:22 %LINK-W-Down:  e3
01-Jan-2000 01:01:22 %LINK-W-Down:  e4
01-Jan-2000 01:01:22 %LINK-W-Down:  e5
01-Jan-2000 01:01:22 %LINK-W-Down:  e6
01-Jan-2000 01:01:22 %LINK-W-Down:  e7
01-Jan-2000 01:01:22 %LINK-W-Down:  e8
01-Jan-2000 01:01:22 %LINK-W-Down:  e9
01-Jan-2000 01:01:23 %LINK-W-Down:  e10
01-Jan-2000 01:01:23 %LINK-W-Down:  e11
01-Jan-2000 01:01:23 %LINK-W-Down:  e12
01-Jan-2000 01:01:23 %LINK-W-Down:  e13
01-Jan-2000 01:01:23 %LINK-W-Down:  e14
01-Jan-2000 01:01:23 %LINK-W-Down:  e15
01-Jan-2000 01:01:23 %LINK-W-Down:  e16
01-Jan-2000 01:01:23 %LINK-W-Down:  e17
01-Jan-2000 01:01:23 %LINK-W-Down:  e18
01-Jan-2000 01:01:23 %LINK-W-Down:  e19
01-Jan-2000 01:01:23 %LINK-W-Down:  e20
01-Jan-2000 01:01:23 %LINK-W-Down:  e21
01-Jan-2000 01:01:23 %LINK-W-Down:  e22
01-Jan-2000 01:01:23 %LINK-W-Down:  e23
01-Jan-2000 01:01:23 %LINK-W-Down:  e24
01-Jan-2000 01:01:23 %LINK-W-Down:  g1
01-Jan-2000 01:01:23 %LINK-W-Down:  g2
01-Jan-2000 01:01:23 %LINK-W-Down:  g3
01-Jan-2000 01:01:23 %LINK-W-Down:  g4
01-Jan-2000 01:01:24 %Box-I-FAN-STAT-CHNG: FAN# 1 status is - operational.
01-Jan-2000 01:01:24 %Entity-I-SEND-ENT-CONF-CHANGE-TRAP: entity configuration change trap.
01-Jan-2000 01:01:24 %Box-I-PS-STAT-CHNG: PS# 1 status is - operational.
01-Jan-2000 01:01:26 %LINK-I-Up:  Vlan 1
01-Jan-2000 01:01:26 %LINK-I-Up:  g3
01-Jan-2000 01:01:56 %STP-W-PORTSTATUS: g3: STP status Forwarding
01-Jan-2000 01:03:30 %INIT-I-Startup: Cold Startup
console>

Предварительное изучение интерфейса CLI

Первое впечателение -CISCO-Like. Хотя, вцелом, менее удобно. (с непривычки). Запись коонфига

copy running-config startup-config
Overwrite file [startup-config] ?[Yes/press any key for no]....
01-Jan-2000 01:49:55 %COPY-I-FILECPY: Files Copy - source URL running-config destination URL flash://startup-config
01-Jan-2000 01:49:58 %COPY-W-TRAP: The copy operation was completed successfully

Посмотреть конфиг

sh run

Итнерфейс управления (в 1-м VLAN)

interface vlan 1
ip address 172.16.37.205 255.255.255.0
exit

Нагрузка

На коммутаторе с пустым конфигом и одним линком (25 порт)

show system tcam utilization
TCAM utilization: 13%
# show cpu utilization
CPU utilization service is on.

CPU utilization
---------------
five seconds:5% ;one minute:5% ;five minutes:6%

Настройка VLAN

В моем случае попробую схемы Vlna-per-Customer, соответвенно у меня каждый из 24 портов в своем влане, магистральные порты - во всех вланах. Управление для простоты в 1-м ВЛАН.

Создаю VLANs 201-224

#configure
vlan database
console(config-vlan)# vlan 201
...
console(config-vlan)# vlan 224
exit

Добавляю порты 1-24 каждый в свой VLAN, режим access (untag в терминах DLink)
В примере порт 2 (e2, в терминах Cisco это был бы Fa0/2). Для остальных - аналогично.
Отмечу немного непривычное именование портов, FastEthernet = e1 - e2, GigabitEthernet = g1 - g3

console# conf#
console(config)# interface ethernet e2
console(config-if)# switchport mode access
console(config-if)# switchport access vlan 202
console(config-if)# description "---=== Access-Port=2 ===---"
console(config-if)# ex
console(config)#
console#                             
Добавляю все вланы во все гигабитные порты.
Порты - trunk.
<PRE>
console# configure
console(config)#interface range ethernet g1,g2,g3,g4
console(config-if)# switchport mode trunk
console(config-if)# switchport trunk allowed vlan
console(config-if)# switchport trunk allowed vlan add 201-224
01-Jan-2000 17:22:09 %LINK-I-Up:  Vlan 201
01-Jan-2000 17:22:09 %LINK-I-Up:  Vlan 202
01-Jan-2000 17:22:09 %LINK-I-Up:  Vlan 203
01-Jan-2000 17:22:09 %LINK-I-Up:  Vlan 204
01-Jan-2000 17:22:09 %LINK-I-Up:  Vlan 205
01-Jan-2000 17:22:09 %LINK-I-Up:  Vlan 206
01-Jan-2000 17:22:09 %LINK-I-Up:  Vlan 207
01-Jan-2000 17:22:09 %LINK-I-Up:  Vlan 208
01-Jan-2000 17:22:09 %LINK-I-Up:  Vlan 209
01-Jan-2000 17:22:09 %LINK-I-Up:  Vlan 210
01-Jan-2000 17:22:09 %LINK-I-Up:  Vlan 211
01-Jan-2000 17:22:09 %LINK-I-Up:  Vlan 212
01-Jan-2000 17:22:09 %LINK-I-Up:  Vlan 213
01-Jan-2000 17:22:09 %LINK-I-Up:  Vlan 214
01-Jan-2000 17:22:09 %LINK-I-Up:  Vlan 215
01-Jan-2000 17:22:09 %LINK-I-Up:  Vlan 216
01-Jan-2000 17:22:09 %LINK-I-Up:  Vlan 217
01-Jan-2000 17:22:09 %LINK-I-Up:  Vlan 218
01-Jan-2000 17:22:09 %LINK-I-Up:  Vlan 219
01-Jan-2000 17:22:09 %LINK-I-Up:  Vlan 220
01-Jan-2000 17:22:09 %LINK-I-Up:  Vlan 221
01-Jan-2000 17:22:09 %LINK-I-Up:  Vlan 222
01-Jan-2000 17:22:09 %LINK-I-Up:  Vlan 223
01-Jan-2000 17:22:09 %LINK-I-Up:  Vlan 224

В конфиге все хранится в достаточно трудночитаемом виде, однако я не назвал бы это серьезной проблемой.

sh run
...
interface ethernet e1
switchport access vlan 201
exit
interface range ethernet g(1-4)
switchport trunk allowed vlan add 201
exit
interface ethernet e2
switchport access vlan 202
exit
interface range ethernet g(1-4)
switchport trunk allowed vlan add 202
exit
...

Настройка SNMP

Вцелом, аналогично всем другим коммутаторам с которыми мне приходилось работать.
Создать view:

snmp-server view ALL 1 included

Задать коммюнити и view. Опционально - IP адресс.

snmp-server community public ro view ALL
show snmp
  Community-String    Community-Access    View name     IP address
-------------------- ------------------ -------------- ------------
      public              read only           ALL           All

Проверить работу: (вывод поскипан).

# snmpwalk -v2c -c public 172.16.1.1 SNMPv2-MIB::sysDescr.0 = STRING: OmniStack LS 6200 SNMPv2-MIB::sysObjectID.0 = OID: SNMPv2-SMI::enterprises.6486.800.1.1.2.2.4.1.1 DISMAN-EVENT-MIB::sysUpTimeInstance = Timeticks: (578270) 1:36:22.70 SNMPv2-MIB::sysContact.0 = STRING: SNMPv2-MIB::sysName.0 = STRING: SNMPv2-MIB::sysLocation.0 = STRING: SNMPv2-MIB::sysServices.0 = INTEGER: 2 SNMPv2-MIB::sysORLastChange.0 = Timeticks: (0) 0:00:00.00 SNMPv2-MIB::sysORID.1 = OID: SNMPv2-SMI::enterprises.89.73 SNMPv2-MIB::sysORDescr.1 = STRING: RS capabilities SNMPv2-MIB::sysORUpTime.1 = Timeticks: (0) 0:00:00.00 IF-MIB::ifNumber.0 = INTEGER: 61 IF-MIB::ifIndex.1 = INTEGER: 1